Indice   FAQ  
Iscriviti  Login
Indice RouterOS RouterOS

Script backup

Tutto su questo sistema operativo linux based - Configurazioni, dubbi, problematiche &....

Script backup

Messaggioda Akkor » sab 9 mag 2020, 15:15

Salve
sto cercando di completare uno script per il backup e vorrei avere delle informazioni che non sono riuscito a trovare online
Se volessi che il backup fosse salvato in una path particolare come una chiavetta usb con una sottocartella backup come sarebbe la corretta formattazione del codice ?

La stessa cosa la chiedo per uno script che dovrebbe prelevare quel file e mandarlo via mail

Spero di essere stato chiaro nella mia richiesta

Grazie
Akkor
Mikrotik-User 10° Liv
Mikrotik-User 10° Liv
 
Messaggi: 10
Iscritto il: mar 5 mag 2020, 11:06
Uso routerOS dalla Versione: v6.x

Re: Script backup

Messaggioda ppraz » sab 9 mag 2020, 20:17

Ciao, dal menù system -> scripts puoi creare gli script
Dal menù scheduler puooi pianificare la loro esecuzione a intervalli regolari
Come script io uso questo:

Codice: Seleziona tutto
:global backupfile ([/system identity get name] . "-" . [:pick [/system clock get date] 7 11] ."-". [:pick [/system clock get date] 0 3] ."-". [:pick [/system clock get date] 4 6])
/export compact file=$backupfile
:log memory "backup pausing for 10s"
:delay 10s
:log memory "backup being emailed"
/tool e-mail send server=smtp.xxxxx.xx to=xxxxxxxxx@gmail.com from="backup@xxxxxxxx.xx" subject=([/system identity get name] . \
" Backup") file=$backupfile
:log memory "backup finished"


Personalizza il server SMTP, il destinatario e il sender
Volendo dal menù tool -> email puoi impostare un server che preveda autenticazione
ppraz
Staff rosIT
Staff rosIT
 
Messaggi: 917
Iscritto il: sab 12 mar 2011, 13:13
Uso routerOS dalla Versione: v3.x

Re: Script backup

Messaggioda Akkor » sab 9 mag 2020, 21:46

ppraz ha scritto:Ciao, dal menù system -> scripts puoi creare gli script
Dal menù scheduler puooi pianificare la loro esecuzione a intervalli regolari
Come script io uso questo:

Codice: Seleziona tutto
:global backupfile ([/system identity get name] . "-" . [:pick [/system clock get date] 7 11] ."-". [:pick [/system clock get date] 0 3] ."-". [:pick [/system clock get date] 4 6])
/export compact file=$backupfile
:log memory "backup pausing for 10s"
:delay 10s
:log memory "backup being emailed"
/tool e-mail send server=smtp.xxxxx.xx to=xxxxxxxxx@gmail.com from="backup@xxxxxxxx.xx" subject=([/system identity get name] . \
" Backup") file=$backupfile
:log memory "backup finished"


Personalizza il server SMTP, il destinatario e il sender
Volendo dal menù tool -> email puoi impostare un server che preveda autenticazione


Ti ringrazio ma se io volessi che il backup venisse fatto su una microsd (che ho chiamato disk1) che ho inserito nel router all'interno della cartella Backup, quindi path disk1/Backup, come dovrei modificare lo script ?
Akkor
Mikrotik-User 10° Liv
Mikrotik-User 10° Liv
 
Messaggi: 10
Iscritto il: mar 5 mag 2020, 11:06
Uso routerOS dalla Versione: v6.x

Re: Script backup

Messaggioda ppraz » sab 9 mag 2020, 22:23

Cambia la prima riga dello script in
Codice: Seleziona tutto
:global backupfile ("disk1/" . [/system identity get name] . "-" . [:pick [/system clock get date] 7 11] ."-". [:pick [/system clock get date] 0 3] ."-". [:pick [/system clock get date] 4 6])
ppraz
Staff rosIT
Staff rosIT
 
Messaggi: 917
Iscritto il: sab 12 mar 2011, 13:13
Uso routerOS dalla Versione: v3.x

Re: Script backup

Messaggioda Akkor » dom 10 mag 2020, 0:02

ppraz ha scritto:Cambia la prima riga dello script in
Codice: Seleziona tutto
:global backupfile ("disk1/" . [/system identity get name] . "-" . [:pick [/system clock get date] 7 11] ."-". [:pick [/system clock get date] 0 3] ."-". [:pick [/system clock get date] 4 6])



Ti ringrazio dell'aiuto :ave:
Ora testo :eheh:
Akkor
Mikrotik-User 10° Liv
Mikrotik-User 10° Liv
 
Messaggi: 10
Iscritto il: mar 5 mag 2020, 11:06
Uso routerOS dalla Versione: v6.x

Re: Script backup

Messaggioda Akkor » dom 10 mag 2020, 0:09

ppraz ha scritto:Cambia la prima riga dello script in
Codice: Seleziona tutto
:global backupfile ("disk1/" . [/system identity get name] . "-" . [:pick [/system clock get date] 7 11] ."-". [:pick [/system clock get date] 0 3] ."-". [:pick [/system clock get date] 4 6])


Io ho fatto queste modifiche ma nn funziona

Codice: Seleziona tutto
:global backupfile ("disk1/Backup/" . [/system identity get name] . "-" . [:pick [/system clock get date] 7 11] ."-". [:pick [/system clock get date] 0 3] ."-". [:pick [/system clock get date] 4 6])
/export compact file=$backupfile
:log memory "backup pausing for 10s"
:delay 10s
:log memory "backup being emailed"
/tool e-mail send to=xxxxxxxxxx@hotmail.com" subject=([/system identity get name] . \
" Backup") file=$backupfile
:log memory "backup finished"
Akkor
Mikrotik-User 10° Liv
Mikrotik-User 10° Liv
 
Messaggi: 10
Iscritto il: mar 5 mag 2020, 11:06
Uso routerOS dalla Versione: v6.x

Re: Script backup

Messaggioda ppraz » dom 10 mag 2020, 9:41

Nascondi la tua email personale!!
Il file viene creato?
La cartella "disk1/Backup/" esiste? Occhio che lui non la crea!

Per l'invio email invece fai prima un test dal menù "tool -> email"
ppraz
Staff rosIT
Staff rosIT
 
Messaggi: 917
Iscritto il: sab 12 mar 2011, 13:13
Uso routerOS dalla Versione: v3.x

Re: Script backup

Messaggioda Akkor » dom 10 mag 2020, 10:09

ppraz ha scritto:Nascondi la tua email personale!!
Il file viene creato?
La cartella "disk1/Backup/" esiste? Occhio che lui non la crea!

Per l'invio email invece fai prima un test dal menù "tool -> email"


Ops hai ragione.......ma non ho la possibilità di rieditare il mio post

cmq la cartella l'avevo già creata......ma il file non viene creato


ps ho notato che il bottone edit ce l'ho solo sui nuovi messaggi......forse dopo un pò scompare........
Akkor
Mikrotik-User 10° Liv
Mikrotik-User 10° Liv
 
Messaggi: 10
Iscritto il: mar 5 mag 2020, 11:06
Uso routerOS dalla Versione: v6.x

Re: Script backup

Messaggioda ppraz » dom 10 mag 2020, 21:56

Ho editato io il post
Ascolta fai così, subito dopo la riga
Codice: Seleziona tutto
:global backupfile ("disk1/Backup/" . [/system identity get name] . "-" . [:pick [/system clock get date] 7 11] ."-". [:pick [/system clock get date] 0 3] ."-". [:pick [/system clock get date] 4 6])


metti la riga
Codice: Seleziona tutto
:log memory $backupfile


Questo scrive una riga di log in "memory" che di default si legge dal menù "log" della routerboard
Nella riga scrive il valore della variabile backupfile
Controlla che sia corretta e munita di tutto il path
Se così non fosse prova a correggere l'uso dell'operatore di concatenazione
ricordati che deve essere "spazio vuoto, puntino, spazio vuoto" non omettere gli spazi vuoti
ppraz
Staff rosIT
Staff rosIT
 
Messaggi: 917
Iscritto il: sab 12 mar 2011, 13:13
Uso routerOS dalla Versione: v3.x

Re: Script backup

Messaggioda Akkor » dom 10 mag 2020, 22:42

ppraz ha scritto:Ho editato io il post
Ascolta fai così, subito dopo la riga
Codice: Seleziona tutto
:global backupfile ("disk1/Backup/" . [/system identity get name] . "-" . [:pick [/system clock get date] 7 11] ."-". [:pick [/system clock get date] 0 3] ."-". [:pick [/system clock get date] 4 6])


metti la riga
Codice: Seleziona tutto
:log memory $backupfile


Questo scrive una riga di log in "memory" che di default si legge dal menù "log" della routerboard
Nella riga scrive il valore della variabile backupfile
Controlla che sia corretta e munita di tutto il path
Se così non fosse prova a correggere l'uso dell'operatore di concatenazione
ricordati che deve essere "spazio vuoto, puntino, spazio vuoto" non omettere gli spazi vuoti


Ok grazie provo
Akkor
Mikrotik-User 10° Liv
Mikrotik-User 10° Liv
 
Messaggi: 10
Iscritto il: mar 5 mag 2020, 11:06
Uso routerOS dalla Versione: v6.x



Torna a RouterOS

Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti