Indice   FAQ  
Iscriviti  Login
Indice RouterOS Wiki routerOSiTalia [GUIDE]

VRRP Cose e a cosa Serve ?

In questa sezione puoi trovare alcune guide su routerOS

VRRP Cose e a cosa Serve ?

Messaggioda bivio87 » gio 16 apr 2020, 11:38

VRRP Cose e a cosa Serve ?

Il VRRP è un modo per avere dei Router di BackUp che si avviano in automatico senza che il gestore di rete intervenga e che i client non si accorgono di nulla ..
In pratica si genera un’ Interfaccia Virtuale con un IP alla quale si collegano i client tramite un controllo automatico dei Router solo uno prende in carico il funzionamento di tale interfaccia; colui chiamato MASTER e avrà la M e la R che sta per MASTER in RUNNING , gli altri saranno con la B di BackUp

Immagine

Come si presenta

Immagine

Ora facciamo un esempio pratico di come usarlo

Allora faremo 2 Passaggi Principali

1) Settare il VRRP
2) Configurare gli IP

Esempio
Eth1_wan = ip dinamico
Eth2_lan sotto eth2 ci sarà il VRRP 192.168.1.1/24

Step 1 Set VRRP

Andiamo in Interface VRRP premiamo +
Nella prima schermata gli diamo un nome Esempio VRRP_interface
Nella seconda schermata scegliamo Interface a cui fa capo ( La LAN su che interface è collegata?)
Pryority = da la priorità al router (100= max 1=minimo) per cui se abbiamo due router uno con priorità 100 e uno con priorità 90 quando sono tutti e due accesi; il VRRP utilizzato sarà quello della priorità 100.
Intreval = il tempo in secondi ogni quanto i Router si parlano e vedono se si rispondono ( il router in di Backup chiama il router master quello in RUN , aspetta un tempo 4 volte più grande del Interval se non ottiene risposta prende lui in comando )

Immagine



Code
Codice: Seleziona tutto
/interface vrrp add interface=ether2 name=vrrp1 priority = 100


Immagine
Step 2 Assegno gli IP

Eth1 che in questo caso è la wan la configuro in dhcp
Codice: Seleziona tutto
/ip dhcp-clien add interface=ether1

Ora ci manca solo più inserire gli ip per il VRRP questi si dividono in 2
Il primo visto dai client che nel nostro caso sarà 192.168.1.1 assegnato al VRRP interface
Codice: Seleziona tutto
/ip address add interface=vrrp1 address=192.168.1.1/24

Altro sarà assegnato all’ interfaccia ETH2 10.10.10.1 ( questo sarà ip col quale i router in VRRP si parlano una sotto rete loro che serve per farsi le chiamate e vedere ci è UP , ogni router avrà il suo ip router 1 10.10.10.1 router 2 10.10.10.2 router 3 10.10.10.3 …. E cosi via per quanti router di BackUp volete)
Codice: Seleziona tutto
/ip address add interface=vrrp1 address=10.10.10.1/24


Adesso configurate TUTTI I ROUTER normalmente con dhcp e tutto il necessario; potrete notare che se uno si spegne altro in cascata secondo le PRIORITA’ si attiverà per sostituirlo.


:thanks: dell'attenzione
Avatar utente
bivio87
Staff rosIT
Staff rosIT
 
Messaggi: 32
Iscritto il: mer 28 giu 2017, 9:47
Uso routerOS dalla Versione: v4.x


Torna a Wiki routerOSiTalia [GUIDE]

Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti