Indice   FAQ  
Iscriviti  Login
Indice RouterOS RouterOS

PPPoE a rete alterna

Tutto su questo sistema operativo linux based - Configurazioni, dubbi, problematiche &....

PPPoE a rete alterna

Messaggioda airouter » dom 15 mar 2020, 18:38

Salve,
è la prima volta che scrivo nel forum, ma è già qualche mese che vi seguo.
Grazie alle varie letture sul forum, sono riuscito a configurare un RB2011UAS-in Mikrotik, in modalità load balance con 3 wan, failover e PPPoE. Che magari può sembrare una cosa banale per le decine di persone che hanno tanto di certificazioni e qualifiche; ma per me, che sono alle prime armi, è stato come scalare il K2. :roll:
I client appena attivi, si registrano regolarmente sulla routerboard (grande soddisfazione). Ma ahimè non hanno connessione e non capisco il motivo e cosa ancor più strana, è che se effettuo un ping 8.8.8.8 dal terminale winbox, alcune volte va ed altre no, per intenderci, su 100 ping, 50-70 non sono a buon fine.
Sicuramente ho sbagliato io da qualche parte, però essendo di vecchia scuola....., una cosa o non funziona totale o funziona, le situazioni di mezzo mi mettono in crisi mistica. :D
airouter
Mikrotik Curious User
Mikrotik Curious User
 
Messaggi: 6
Iscritto il: dom 15 mar 2020, 18:25
Uso routerOS dalla Versione: v6.x

Re: PPPoE a rete alterna

Messaggioda airouter » lun 16 mar 2020, 2:40

Problema appena risolto.
C'era un ip di un tablet nella rete, che aveva come indirizzo ip secondario, lo stesso ip di una delle porte WAN della rb2011, non lo avevo notato proprio perche era secondario, MEA CULPA.

Ho una seconda RB2011, che deve fare un altro lavoro, ma aprirò un nuovo messaggio.
airouter
Mikrotik Curious User
Mikrotik Curious User
 
Messaggi: 6
Iscritto il: dom 15 mar 2020, 18:25
Uso routerOS dalla Versione: v6.x

Re: PPPoE a rete alterna

Messaggioda airouter » mar 17 mar 2020, 4:05

Sto notando una cosa abbastanza strana. La rete interna entra in totale collisione di pacchetti sull'uscita del load balance.
Sto vedendo tramite il torch nella routerboard, che tutti gli indirizzi ip della rete LAN, inviano pacchetti ad 8.8.8.8 ed 8.8.4.4, entra come in loopback, e mi fa perdere la rete internet.
Se collego la rete al router telecom, invece tutto ok.
Vi posto la configurazione, non vorrei aver fatto qualche baggianata

RouterOS 6.46.4

Codice: Seleziona tutto
/interface ethernet
set [ find default-name=ether1 ] name=WAN-OUT
set [ find default-name=ether2 ] name=WAN1
set [ find default-name=ether3 ] name=WAN2
set [ find default-name=ether4 ] name=WAN3
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=PPPoE-Pool ranges=10.10.70.2-10.10.70.254
/ppp profile
add dns-server=8.8.8.8,8.8.4.4 local-address=10.10.70.1 name=PPPoE_User remote-address=PPPoE-Pool
/interface pppoe-server server
add authentication=mschap2 disabled=no interface=WAN-OUT keepalive-timeout=disabled one-session-per-host=yes service-name=PPPoE_Server
/ip address
add address=172.16.0.1/24 interface=WAN-OUT network=172.16.0.0
add address=192.168.0.225/24 interface=CONSOLE network=192.168.0.0
add address=192.168.3.2/24 interface=WAN1 network=192.168.3.0
add address=192.168.4.2/24 interface=WAN2 network=192.168.4.0
add address=192.168.5.2/24 interface=WAN3 network=192.168.5.0
/ip firewall mangle
add action=accept chain=prerouting dst-address=192.168.3.0/24 in-interface=WAN-OUT
add action=accept chain=prerouting dst-address=192.168.4.0/24 in-interface=WAN-OUT
add action=accept chain=prerouting dst-address=192.168.5.0/24 in-interface=WAN-OUT
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=WAN1 new-connection-mark=WAN1_conn passthrough=no
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=WAN2 new-connection-mark=WAN2_conn passthrough=no
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=WAN3 new-connection-mark=WAN3_conn passthrough=no
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local in-interface=WAN-OUT new-connection-mark=WAN1_conn passthrough=no per-connection-classifier=\
    both-addresses:3/0
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local in-interface=WAN-OUT new-connection-mark=WAN2_conn passthrough=no per-connection-classifier=\
    both-addresses:3/1
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local in-interface=WAN-OUT new-connection-mark=WAN3_conn passthrough=no per-connection-classifier=\
    both-addresses:3/2
add action=mark-routing chain=prerouting connection-mark=WAN1_conn in-interface=WAN-OUT new-routing-mark=to_WAN1 passthrough=no
add action=mark-routing chain=prerouting connection-mark=WAN2_conn in-interface=WAN-OUT new-routing-mark=to_WAN2 passthrough=no
add action=mark-routing chain=prerouting connection-mark=WAN3_conn in-interface=WAN-OUT new-routing-mark=to_WAN3 passthrough=no
add action=mark-routing chain=output connection-mark=WAN1_conn new-routing-mark=to_WAN1 passthrough=no
add action=mark-routing chain=output connection-mark=WAN2_conn new-routing-mark=to_WAN2 passthrough=no
add action=mark-routing chain=output connection-mark=WAN3_conn new-routing-mark=to_WAN3 passthrough=no
/ip firewall nat
add action=masquerade chain=srcnat out-interface=WAN1
add action=masquerade chain=srcnat out-interface=WAN2
add action=masquerade chain=srcnat out-interface=WAN3
/ip route
add check-gateway=ping distance=1 gateway=192.168.3.1 routing-mark=to_WAN1
add check-gateway=ping distance=1 gateway=192.168.4.1 routing-mark=to_WAN2
add check-gateway=ping distance=1 gateway=192.168.5.1 routing-mark=to_WAN3
add check-gateway=ping distance=1 gateway=192.168.3.1
add check-gateway=ping distance=2 gateway=192.168.4.1
add check-gateway=ping distance=3 gateway=192.168.5.1
/ppp secret
add name=ufficio password=forzaazzurri profile=PPPoE_User service=pppoe
airouter
Mikrotik Curious User
Mikrotik Curious User
 
Messaggi: 6
Iscritto il: dom 15 mar 2020, 18:25
Uso routerOS dalla Versione: v6.x



Torna a RouterOS

Chi c’è in linea

Visitano il forum: Nessuno e 17 ospiti