Indice   FAQ  
Iscriviti  Login
Indice RouterOS RouterOS

Distribuire IP pubblici intestati a PPPoE Client

Tutto su questo sistema operativo linux based - Configurazioni, dubbi, problematiche &....

Distribuire IP pubblici intestati a PPPoE Client

Messaggioda claudiolalo » mar 3 mar 2020, 17:43

Ciao a tutti, ho un grande dubbio che non so come affrontare.
Vi chiedo un aiuto o almeno un indicazione sulla giusta strada in modo che possa approfondire il tema e cercare di venirne a capo.
Allego un piccolo schema sul quale segue questo ragionamento>
Ho un CCR1009 in produzione con 6 ip statici intestati in una interfaccia PPPoE Client.
Devo portare uno di questi indirizzi a una RB2011 in modo che sia intestato alla interfaccia ether1.
L'unica cosa che mi viene in mente e' di creare sul CCR un bridge-wan con pppoe-client e ether2(che e' libera) a questo punto collego la ether2 alla ether1 della RB e configuro l' ip statico direttamente sulla ether1.

Non so se sia il modo corretto di farlo. Avete altre idee opinioni, potrebbe funzionare?

Grazie
Non hai i permessi necessari per visualizzare i file allegati in questo messaggio.
claudiolalo
Mikrotik Curious User
Mikrotik Curious User
 
Messaggi: 3
Iscritto il: ven 31 gen 2020, 9:36
Uso routerOS dalla Versione: v4.x
Certificazioni Mikrotik: MTCNA,MTCRE

Re: Distribuire IP pubblici intestati a PPPoE Client

Messaggioda figheras » mer 4 mar 2020, 10:17

Ciao, se gli ip sono stati ruotati sul client pppoe devi soltanto aggiungere la subnet sull'interfaccia che preferisci e collegare la 2011 usando quell'interfaccia e quella subnet (sempre se ho capito bene ciò che hai scritto), non dimenticare di escludere dal nat la subnet pubblica se hai il masquerade sul 1009.
Siamo tutti ignoranti. Ma non tutti ignoriamo le stesse cose! - Einstein -
Avatar utente
figheras
Staff rosIT
Staff rosIT
 
Messaggi: 1200
Iscritto il: sab 19 set 2009, 19:09
Uso routerOS dalla Versione: v2.9.x
Certificazioni Mikrotik: MTCNA, MTCRE, MTCWE
Preferred Training Centre: Grifonline
Altre certificazioni: KalliopePBX

Re: Distribuire IP pubblici intestati a PPPoE Client

Messaggioda claudiolalo » mer 4 mar 2020, 12:15

Beh inanzitutto grazie della risposta, ho scritto pochissime volte sul forum perche' cerco sempre di arrangiarmi ma le poche volte che ho scritto mi hai SEMPRE aiutato, e ti ringrazio davvero.
Il mio secondo problema adesso e' capire cosa hai scritto :D

A parte gli scherzi:

IP su CCR
Codice: Seleziona tutto
/ip address
add address=10.5.2.1/16 comment="LAN" interface=bridge-LAN network=10.5.0.0
add address=109.168.*.2/29 interface=pppoe-SHDSL network=109.168.*.1
add address=109.168.*.3/29 interface=pppoe-SHDSL network=109.168.*.1
add address=109.168.*.4/29 interface=pppoe-SHDSL network=109.168.*.1
add address=109.168.*.5/29 interface=pppoe-SHDSL network=109.168.*.1
add address=109.168.*.6/29 interface=pppoe-SHDSL network=109.168.*.1
add address=109.168.*.7/29 interface=pppoe-SHDSL network=109.168.*.1


Nat su CCR
Codice: Seleziona tutto
/ip firewall nat
add action=masquerade chain=srcnat comment="masquerade for SHDSL" out-interface=pppoe-SHDSL
add action=masquerade chain=srcnat comment="masquerade for TIM FTTC" out-interface=pppoe-TIM-FTTC


Collego fisicamente la Ether7 del CCR che e' libera alla Ether1 della 2011 quindi nel CCR cambio interfaccia internace in interface=ether7

Codice: Seleziona tutto
add address=109.168.*.7/29 interface=ether7 network=109.168.*.1


Corretto?

Mi dispiace ma non so come si fa ad escludere dal masquerade una subnet.
Codice: Seleziona tutto
add action=masquerade chain=srcnat comment="masquerade for SHDSL" out-interface=pppoe-SHDSL


Grazie ancora
claudiolalo
Mikrotik Curious User
Mikrotik Curious User
 
Messaggi: 3
Iscritto il: ven 31 gen 2020, 9:36
Uso routerOS dalla Versione: v4.x
Certificazioni Mikrotik: MTCNA,MTCRE



Torna a RouterOS

Chi c’è in linea

Visitano il forum: Nessuno e 19 ospiti