Indice   FAQ  
Iscriviti  Login
Indice RouterOS RouterOS

VPN ike2 no ping lan

Tutto su questo sistema operativo linux based - Configurazioni, dubbi, problematiche &....

Re: VPN ike2 no ping lan

Messaggioda z3nith » lun 3 dic 2018, 12:47

z3nith ha scritto:
ppraz ha scritto:La cosa più semplice è il src-nat
src-address la subnet della VPN
dst-address la subnet della LAN
action masquerade



Ho provato ma nemmeno così riesco a pingare il client dietro al Mikrotik.
Cmq le subnet sono uguali il pool che ho assegnato alla vpn è uguale alla lan che sta collegata al mikrotik.
C'è modo di vedere tramite i log se il firewall blocca l'acceso o il NAT è sbagliato???
Aggiungendo il NAT che mi hai suggerito io non vedo passare traffico.
NAT 192.168.x.0/32 vpn pool 192.168.x.0/24 lan mikrotik masquerade.

Altra cosa, vedo che l'ip che il pool assegna al pc esterno remoto fa si parte del pool ma non ha gateway.

Grazie.


Risolto, o almeno credo.

ho aggiunto una regola di nat con action masquerade e come regola ipsec policy in ipsec. Nessuna lan e nessuna interfaccia di in out.
Adesso pingo il client che sta dietro al mikrotik e vedo passare il traffico per questa regola.
Cosa strana, se riapro la regola, sembra che la policy ipsec in ipsec non sia configurata ma se disabilito questo NAT torna a non funzionare.....
z3nith
Mikrotik-User 10° Liv
Mikrotik-User 10° Liv
 
Messaggi: 13
Iscritto il: mar 3 lug 2018, 11:33
Uso routerOS dalla Versione: v6.x

Re: VPN ike2 no ping lan

Messaggioda z3nith » lun 3 dic 2018, 16:17

E' corretto?
Anche nella configurazione del peers vedo che mode configuration è come se non fosse configurato in realtà io l'ho messa la mode configuration. Infatti se non metto nulla la vpn non funziona.
Una volta configurata, se rientro dentro peers mode configuration sembra non esserci.


Grazie.
z3nith
Mikrotik-User 10° Liv
Mikrotik-User 10° Liv
 
Messaggi: 13
Iscritto il: mar 3 lug 2018, 11:33
Uso routerOS dalla Versione: v6.x

Re: VPN ike2 no ping lan

Messaggioda ppraz » gio 6 dic 2018, 11:53

Se funziona... è corretto.
Io avrei messo la subnet dell'ipsec diversa dalla subnet lan, in quel modo avrebbe funzionato.
Ma ripeto, if it works, don't fix it.
ppraz
Staff rosIT
Staff rosIT
 
Messaggi: 788
Iscritto il: sab 12 mar 2011, 13:13
Uso routerOS dalla Versione: v3.x

Re: VPN ike2 no ping lan

Messaggioda z3nith » dom 9 dic 2018, 9:54

ppraz ha scritto:Se funziona... è corretto.
Io avrei messo la subnet dell'ipsec diversa dalla subnet lan, in quel modo avrebbe funzionato.
Ma ripeto, if it works, don't fix it.


Non sto capendo più nulla......
Dopo aver salvato la configurazione, ho provato ad eseguire tutta la configurazione da zero per capire se tutto funzionava correttamente e invece no. La regola di NAT che ho utilizzato per far funzionare il PING non posso più metterla mi dice Couldn't change NAT Rule - ipsec-policy out policy not possible in postrouting and local-out chains (6).....
Ho provato a rimettere la configurazione salvata, la VPN funziona, ma della famosa regola di NAT non c'è traccia e se provo a metterla, stesso errore di cui sopra....
Dopo vari tentativi anche rimettendo la configurazione funzionante la VPN si connette ma non riesco più a pingare la lan.
Ho provato a seguire passo passo questa guida
https://wiki.mikrotik.com/wiki/Manual:I ... entication
Inserendo anche le due subnet diverse, come da te suggerito, ma niente, la vpn si connette senza problemi ma non riesco a pingare nulla. Utilizzando le due subnet differenti non pingo nemmeno il mikrotik cosa che invece succede se uso un pool che fa parte della subnet.
Non riesco a capire cosa sbaglio......
Il NAT?


Saluti.
z3nith
Mikrotik-User 10° Liv
Mikrotik-User 10° Liv
 
Messaggi: 13
Iscritto il: mar 3 lug 2018, 11:33
Uso routerOS dalla Versione: v6.x

Re: VPN ike2 no ping lan

Messaggioda z3nith » dom 9 dic 2018, 17:22

Dopo svariati tentativi sono riuscito a far rifunzionare la vpn con la vecchia configurazione....
La regola di NAT corretta è un semplice srcnat masq e basta. Con questa regola riesco ad accedere e pingare tutta la network dietro al mikrotik.
Ho provato anche a configurare la VPN utilizzando una subnet diverse per i clients che si collegano ma, in questo caso, anche aggiungendo le regole di NAT suggerite nei posts precedenti, non sono riuscito a pingare nè il mikrotik nè i pc dietro di esso. Mi potete aiutare?
z3nith
Mikrotik-User 10° Liv
Mikrotik-User 10° Liv
 
Messaggi: 13
Iscritto il: mar 3 lug 2018, 11:33
Uso routerOS dalla Versione: v6.x

Re: VPN ike2 no ping lan

Messaggioda radiation » dom 9 dic 2018, 21:03

Che cosa mascheri la subnet della VPN?
Andrea
Avatar utente
radiation
Staff rosIT
Staff rosIT
 
Messaggi: 413
Iscritto il: mer 11 dic 2013, 19:00
Uso routerOS dalla Versione: v3.x
Certificazioni Mikrotik: MTCNA, MTCWE
Preferred Training Centre: Nimwave

Re: VPN ike2 no ping lan

Messaggioda z3nith » lun 10 dic 2018, 0:46

radiation ha scritto:Che cosa mascheri la subnet della VPN?



la network che sta dietro al mikotik ha indirizzamento 192.168.5.0/24.
Il pool della vpn è 192.168.10.0/24.
I nat che ho configurato sono:
scrnat masquerade
srcnat scr addr 192.168.10.0/24 dst addr 192.168.5.0/24 masquerade
srcnat scr addr 192.168.5.0/24 dst addr 192.168.10.0/24 masquerade
Ho provato anche a settarle come ACCEPT invece che MASQUERADE ma niente.
Il client da cui mi collego prende IP 192.168.10.10/32 e da esso non riesco a pingare nulla della rete 192.168.5.0/24.
Ho provato anche ad aggiungere lo SPLIT nel mode config e una regola di firewall con il forward scr addr 192.168.10.0/24 dest addr 192.168.5.0/24 (con o senza out interface ether wan) ma niente.

Grazie.
z3nith
Mikrotik-User 10° Liv
Mikrotik-User 10° Liv
 
Messaggi: 13
Iscritto il: mar 3 lug 2018, 11:33
Uso routerOS dalla Versione: v6.x

Re: VPN ike2 no ping lan

Messaggioda radiation » lun 10 dic 2018, 0:56

Togli le destination. Devi solo mascherare i pacchetti della subnet VPN (o LAN... non conosco il resto della conf).
La regola è una semplice masquerade
Andrea
Avatar utente
radiation
Staff rosIT
Staff rosIT
 
Messaggi: 413
Iscritto il: mer 11 dic 2013, 19:00
Uso routerOS dalla Versione: v3.x
Certificazioni Mikrotik: MTCNA, MTCWE
Preferred Training Centre: Nimwave

Re: VPN ike2 no ping lan

Messaggioda z3nith » lun 10 dic 2018, 9:01

radiation ha scritto:Togli le destination. Devi solo mascherare i pacchetti della subnet VPN (o LAN... non conosco il resto della conf).
La regola è una semplice masquerade


Buongiorno,

ho appena inserito una regola di NAT come da te indicato per mascherare il traffico che arriva dalla vpn e che ha subnet differente. Niente non riesco a pingare nulla.
z3nith
Mikrotik-User 10° Liv
Mikrotik-User 10° Liv
 
Messaggi: 13
Iscritto il: mar 3 lug 2018, 11:33
Uso routerOS dalla Versione: v6.x

Re: VPN ike2 no ping lan

Messaggioda z3nith » mer 12 dic 2018, 9:53

Ho provato a leggere altre guide, ho letto di persone che fanno bridge strani, ho provato tutti i NAT possibili e immaginabili ma niente. Se uso due subnet differenti, la vpn si connette ma non pingo la lan.

Cosa posso fare?
z3nith
Mikrotik-User 10° Liv
Mikrotik-User 10° Liv
 
Messaggi: 13
Iscritto il: mar 3 lug 2018, 11:33
Uso routerOS dalla Versione: v6.x


PrecedenteProssimo

Torna a RouterOS

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti