Indice   FAQ  
Iscriviti  Login
Indice RouterOS Wiki routerOSiTalia [GUIDE]

Hairpin / NatloopBack configurazione

In questa sezione puoi trovare alcune guide su routerOS

Hairpin / NatloopBack configurazione

Messaggioda bivio87 » lun 13 apr 2020, 10:51

Salve a tutti !!
In questi giorni di quarantena mi sto dedicando un po' al forum di RouterOS
Scrivo la prima di un po’ di guide che vorrei postare ..
Come da titolo Iniziamo con Hairpin / NatloopBack che ultimamente sta diventando più comodo che mai.
Prima di iniziare spieghiamo a cosa serve : semplice puntando il nostro IP Pubblico da dentro la rete facciamo finta che arriviamo da fuori ,certi gestori come TIM questo lavoro lo fanno senza che noi scriviamo regole precise …ma ormai parecchi ISP sgravano la centrale di questo carico , e a noi viene riportato “Impossibile Conettersi “ …ormai con domotica telecamere ecc .. diventa fastidioso configurare due volte la stessa connessione una per quando sono fuori casa e una quando sono in casa.. certo questo non vale se usiamo i cloud (cosa che sconsiglio vivamente per ovvi motivi!!)
Faremo un esempio per la spiegazione:

IP Lan su eth2 = 192.168.1.1/24
IP Wan eth1 = Dinamico!!
Dobbiamo arrivare all ip 192.168.1.22 sulla porta 883

Ma iniziamo la Guida con la prima regola –
Diciamo al router di mascherare le richieste che arrivano dalla Lan e vanno Verso la Lan e come Out la Nostra interfaccia Lan (questo è la creazione del LOOP)
Codice: Seleziona tutto
/ip firewall nat add chain=srcnat dst-address=192.168.1.0/24 src-address=192.168.1.0/24 out-interface=ether2 action=masquerade

Adesso spieghiamo a RouterOS che IP a la nostra Wan
Per farlo useremo un trucchetto niente male attiviamo il Coud Di Router OS
Codice: Seleziona tutto
/ip cloud set ddns-enabled=yes

Cosi abbiamo creato un ddns proprietario di Mikrotik ; badate bene Legato alla Routerboard, se avete un vostro DDNS esempio dynu o cose simili usate quello ok.. e saltate attivazione del cloud
Torniamo a noi se andiamo con Winbox in IP CLOUD copiamo il link che sarà simile a

xxxxxxxxxxx.sn.mynetname.net

Codice: Seleziona tutto
/ip firewall address-list add address= xxxxxxxxxxx.sn.mynetname.net list=Wan

Cosa abbiamo fatto ? abbiamo creato una lista chiamata Wan che come IP avrà IP del nostro cloud!! Se funziona in winbox sotto a questa regola deve apparire un'altra riga Dinamica con il nostro IP pubblico!
ATTENZIONE : questo serve perché se per caso abbiamo due impianti uno a casa e uno in ufficio e noi gli diciamo di girare tutte le chiamate a quella porta ,non entreremmo più nelle telecamere del ufficio se siamo a casa! Invece cosi vediamo dopo come la regola vale Solo per le chiamate al nostro IP pubblico che stiamo usando
Ora abbiamo configurato le regole generali, ci manca solo la configurazione precisa per ogni porta che dobbiamo avere un LoopBack
Codice: Seleziona tutto
/ip firewall nat add chain=dstnat protocol=tcp dst-port=883 src-address-list=Wan action=dst-nat to-addresses=192.168.1.22 port=883 dst-address-type=!local


E avete finito spero di aver spiegato bene !!!
:beer: :beer:
Avatar utente
bivio87
Staff rosIT
Staff rosIT
 
Messaggi: 32
Iscritto il: mer 28 giu 2017, 10:47
Uso routerOS dalla Versione: v4.x

Re: Hairpin / NatloopBack configurazione

Messaggioda Claudio69 » mer 27 gen 2021, 12:41

Grazie ottimo!
Claudio69
Mikrotik Curious User
Mikrotik Curious User
 
Messaggi: 4
Iscritto il: mar 27 nov 2018, 16:26
Uso routerOS dalla Versione: v6.x

Re: Hairpin / NatloopBack configurazione

Messaggioda Danielino1981 » mar 12 lug 2022, 22:26

Buonasera
Se avessi bisogno di tutte le porte? anzichè una di una sola internamente, non devo mettere niente?
grazie
Danielino1981
Mikrotik Curious User
Mikrotik Curious User
 
Messaggi: 3
Iscritto il: dom 16 lug 2017, 18:20
Uso routerOS dalla Versione: v2.9.x



Torna a Wiki routerOSiTalia [GUIDE]

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite