Indice   FAQ  
Iscriviti  Login
Indice RouterOS RouterOS

VRRP con Cisco e IP secondari

Tutto su questo sistema operativo linux based - Configurazioni, dubbi, problematiche &....

VRRP con Cisco e IP secondari

Messaggioda arryxyz » lun 29 apr 2019, 15:48

Buongiorno a tutti.
Ho riscontrato un problema con la configurazione del VRRP tra un Mikrotik RB3011 e un Cisco.

La configurazione prevede un'interfaccia LAN (bridge1) con più classi private:
Codice: Seleziona tutto
/ip address
add address=172.31.100.2/23 interface=bridge1 network=172.31.100.0
add address=10.90.0.2/24  interface=bridge1 network=10.90.0.0
add address=192.168.90.251/24 interface=bridge1 network=192.168.90.0

add address=172.31.100.1 interface=vrrp1 network=172.31.100.1
add address=10.90.0.1 interface=vrrp1 network=10.90.0.1
add address=192.168.90.253 interface=vrrp1 network=192.168.90.253


Lato Cisco, la corrispondente configurazione è la seguente:
Codice: Seleziona tutto
interface Vlan1
ip address 192.168.90.252 255.255.255.0 secondary
ip address 10.90.0.3 255.255.255.0 secondary
ip address 172.31.100.3 255.255.254.0
vrrp 1 ip 172.31.100.1
vrrp 1 ip 10.90.0.1 secondary
vrrp 1 ip 192.168.90.253 secondary
end


Il VRRP "non si mette d'accordo" sui router. Abilitando un debug su Cisco, ho notato che il VRRP non sale perché i pacchetti si stanno parlando su due classi di rete diverse, pur appartenendo alle stesse interfacce: il Mikrotik negoziava sulla rete 10.90.0.0, mentre il Cisco sulla 172.31.100.0, essendo la sua principale.

Per risolvere il problema, ho invertito gli IP sul Cisco, configurando la classe 10.90.0.0 come principale. In questo assetto tutto ha iniziato a funzionare.

La domanda è: c'è modo di configurare il Mikrotik in modo da governare questo aspetto? In pratica un modo per specificare che una delle 3 reti sia la principale, analogamente a quanto fatto su Cisco?

Grazie e buona giornata.
Arrigo
arryxyz
Mikrotik Curious User
Mikrotik Curious User
 
Messaggi: 3
Iscritto il: ven 27 lug 2018, 10:05
Uso routerOS dalla Versione: v6.x


Torna a RouterOS

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti